Bikes we used to have

Drop your classic bike pics in here................
Japanese, British, vintage, pre-war, classic superbike, were're not prejudiced!

Re: Bikes we used to have

Postby GBC » Wed Nov 25, 2009 10:23 pm

This is the bike I learnt to ride on, a Yammy TDR 125. A cracking little bike rock
You do not have the required permissions to view the files attached to this post.
User avatar
GBC
 
Posts: 485
Joined: Wed Jun 24, 2009 8:58 am
Location: Scotland

Re: Bikes we used to have

Postby Stuart SS » Fri Nov 27, 2009 12:36 pm

Yep thats it.. sounds like it... timing chain rattling .. carbs rattling..

My old K2 Honda.. mine was blue.. squawking front brake.. hated short running and fouled plugs although did not use oil ~ handled like a bucket of bolts.. vibrated like all the be jeeze ~ But flog it and it just kept coming back for more.

http://www.topspeed.com/motorcycles/mot ... 40344.html
User avatar
Stuart SS
Global Moderator
 
Posts: 1225
Joined: Sat Jun 27, 2009 5:59 am
Location: Or-strailia's tropical paradise; Far Far North Queensland !

Re: Bikes we used to have

Postby The Doctor » Sat Nov 28, 2009 1:54 pm

We are going to add a periodic picture section for old classic bike pictures, seems you have made a head start on me!

Please send more old pics, either by replying to this thread or sending to info@classic-motorbikes.net.
User avatar
The Doctor
Site Admin
 
Posts: 437
Joined: Thu May 28, 2009 11:21 pm

Re: Bikes we used to have

Postby 850norton » Sun Nov 29, 2009 2:30 am

Had one of these though not this color, a Honda CB 250 K4

cb250.jpg


No picture of the 59 Triumph 5TA oil well I had

Got one liike this at Gus Kuhn's in 77

Norton 850 jpn colors.jpg
You do not have the required permissions to view the files attached to this post.
You sick little monkey!!!!!

http://www.thrashemmotorcycles.blogspot.com

'68 BSA B25 Sarfire, '70 BSA B44 Victor Special
User avatar
850norton
 
Posts: 204
Joined: Sun Aug 30, 2009 4:03 pm
Location: Kings Sutton, Banbury, OXON and Elmendorf, Texas

Re: Bikes we used to have

Postby Alpinebiker » Wed Dec 09, 2009 9:06 am

My old Yamaha XS2 back in 1973. Picture was taken after an overnight stop in Italy on the way back from Greece. The ploughed field in the background was all grass when we put the tent up the night before. The farmer had been up early!
Image
Alpinebiker
 
Posts: 1
Joined: Mon Jul 13, 2009 12:00 pm

Re: Bikes we used to have

Postby MOUSE » Thu Dec 10, 2009 8:07 am

Or you were up late, thanks for sharing :151
"My arthritis has gotten so bad I can hardly grip anything, my cataracts seem to get worse every day, I have gout in my right leg and can't bend my knee and I can't hear anything.
But thank God I can still ride
User avatar
MOUSE
 
Posts: 1298
Joined: Wed Jun 24, 2009 9:43 am
Location: 4,842 kilometers from Antartica

Re: Bikes we used to have

Postby GNC » Thu Dec 10, 2009 8:35 am

My 1st bike XL250 can't remember year, was used to get to work, had no shed so in the dinning room it lived. Copper put it off the road no fine just a stern warning not to let him see it on road again.

Image
T140E
User avatar
GNC
Site Admin
 
Posts: 654
Joined: Wed Jun 24, 2009 8:18 pm
Location: NZ

Re: Bikes we used to have

Postby kawa » Fri Dec 18, 2009 9:44 pm

Just found this pic of a 94 HD Sporster we bought, only had it 18mths cause the wife prefered using an old FZ400R to run around on and it just sat in the shed.

Image
User avatar
kawa
 
Posts: 253
Joined: Fri Jul 03, 2009 7:01 pm
Location: Second wall next to the wheel, Alba

Re: Bikes we used to have

Postby The Doctor » Sat Feb 20, 2010 9:18 pm

I would like to use the images on our HUGE classic bike gallery please?

Please let me know whether this will be ok?

Thanks


Doc
User avatar
The Doctor
Site Admin
 
Posts: 437
Joined: Thu May 28, 2009 11:21 pm

Re: Bikes we used to have

Postby oldmalc » Sat Feb 27, 2010 10:48 am

Here is a photo of me on my 500 v twin 1935 BSA taken in 1950 when I was seventeen, not a helmet in sight! The bike almost hidden at the rear was a gorgeous Triumph Trophy, as ridden by The Fonze.
You do not have the required permissions to view the files attached to this post.
Kind regards to all, and ride safely. Malc.

http://www.mwells.me.uk
User avatar
oldmalc
 
Posts: 38
Joined: Mon Feb 01, 2010 4:25 pm
Location: Frome,Somerset

PreviousNext

Return to Photo Gallery

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron