Z900A4 electrical gremlin ?

Z900A4 electrical gremlin ?

Postby Hammo » Wed May 04, 2011 8:17 pm

I have a 1976 Z900A4 battery is going dead after short runs i found the 20amp fuse blown still investigating why it blew , is the regulator/rectifier a combined unit ? any help is welcome .
Hammo
 
Posts: 6
Joined: Wed Apr 27, 2011 7:44 pm

Re: Z900A4 electrical gremlin ?

Postby chimp1 » Wed May 04, 2011 11:15 pm

G'day Hammo this is from my z650, & should be the same
13 Regulator 4 rectifier.tif

cheers pete
You do not have the required permissions to view the files attached to this post.
User avatar
chimp1
 
Posts: 45
Joined: Thu Dec 02, 2010 1:52 am

Re: Z900A4 electrical gremlin ?

Postby Hammo » Thu May 05, 2011 5:36 pm

Cheers i,ll let you know how i get on !!!!!!!!!!!!!!!
Hammo
 
Posts: 6
Joined: Wed Apr 27, 2011 7:44 pm

Re: Z900A4 electrical gremlin ?

Postby Stuart SS » Fri May 06, 2011 1:33 am

I have had soem electrical experience with the Z900 ~

The regulator and alternator are separate as is the Rectifier ~

To test the alternator you simply put a voltmeter across the battery and then unplug the regulator ~ (which was situated under the seat about centre board and centre tube of the frame.

Start up and watch the voltmeter ~ if all OK when you run the revs up and as long as the voltmeter rises to 14.5 volts all is fine ~

Don't go rev the crap out of it just to see how far the volt-meter will go !!! Anything above 14.50 is heading for critical mass ~ and could be detrimental ~

Don't go there ~ OK !

As for blown fuse.. ???
User avatar
Stuart SS
Global Moderator
 
Posts: 1225
Joined: Sat Jun 27, 2009 5:59 am
Location: Or-strailia's tropical paradise; Far Far North Queensland !


Return to Kawasaki

Who is online

Users browsing this forum: No registered users and 2 guests

cron